PHP Classes

PHP 4 Compatability

Recommend this page to a friend!

      Podcast Parser  >  All threads  >  PHP 4 Compatability  >  (Un) Subscribe thread alerts  
Subject:PHP 4 Compatability
Summary:PHP 4 equivalent for simplexml_load_string
Messages:2
Author:Kim Burgess
Date:2006-04-25 13:31:00
Update:2006-04-26 17:02:21
 

 


  1. PHP 4 Compatability   Reply   Report abuse  
Picture of Kim Burgess Kim Burgess - 2006-04-25 13:31:00
Hi, i've only recently started programming in php and am in the middle of developing a LAMP driven site (http//www.pipod.tv). I have been testing it locally using php5 and things have been going well but when I uploaded it the the machine it will be hosted on it didn't go quite as smoothly as planned. After a bit of debugging i managed to locate simplexml_load_string as the source of my problems. Basically its a php5 thing and the host only runs php4. Is there a php4 equivalent or am I going to have to right a new xml parsing class?

  2. Re: PHP 4 Compatability   Reply   Report abuse  
Picture of Piotr Malinski Piotr Malinski - 2006-04-26 17:02:21 - In reply to message 1 from Kim Burgess
there is no easy one function way to do it in PHP4. If you have PHP4 only then you have to use another class that makes array <--> xml operations.